Bose SoundDock series 1 USB power mod

English version
Scroll down (or click here) for an english version of this article.

Und wieder einmal kam beim Dumpster Diving ein interessantes Stück Technik zum Vorschein: Ein Bose SoundDock inklusive Netzteil (allerdings ohne Fernbedienung :/ ). Ein erster Test mit meinem iPod Touch 3G ergab, dass das Ding quasi noch voll funktionsfähig war, bis auf einen kleinen Wackler an der Netzteilbuchse, die offenbar etwas grob behandelt wurde. Mit etwas Liebe ließ sich das aber wortwörtlich wieder „hinbiegen“. Soweit sogut, ein funktionierendes Soundsystem mit recht gutem Sound für seine Größe und wieder etwas weniger Schrott, wenn da nicht diese komische Anzeige auf dem iPod wäre: „Aufladen mit diesem Zubehör wird nicht unterstützt“… Da ich mit Apfelprodukten nicht so viel am Hut habe, musste ich erstmal googeln was es damit nu wieder auf sich hat. Es stellte sich dann heraus, dass die ersten i-Pid/Pad/Pud-Generationen per FireWire geladen wurden, also mit 12V oder mehr, und mein „3G“ mit 5V via USB. Also das Dock aufgemacht und geguckt was es da „spannendes“ drin gibt.

Betrieben wird das Dock mit einem Schaltnetzteil welches 2 x 18V zu je 1A liefert. Ebendiese 18V fanden sich dann auch auf dem FireWire-Power-Pin. Im Innern fanden sich dann noch zwei lineare Regler, die 3.3V und 1.xV für die Digitaltechnik aufbereiten. Von 5V also keine Spur 🙁 . Na gut, dachte ich, bleibt mir also nichts anderes übrig, als irgendwo 5V herzuzaubern. Bei bis zu 2A Ladestrom war ein weiterer LM317 natürlich keine Lösung, also musste da ein Schaltregler mit rein in die Kiste. Im Lager war nix passendes, also habe ich einen LM2576 im DDPAK bestellt, dazu eine dicke Schottky-Diode und einen kleinen 1000uF/6.3V-Elko. Eine Induktivität gab’s bei ASWO nicht, also musste Eine mit 47uH aus ’ner LCD-TV-Digital-Audio-Endstufe herhalten. Den Regler gibt’s direkt als 5V-Version, was den externen Bauteileaufwand erfreulich gering hält: Spule, Diode, Elko, fertig.

Den vorhandenen Platz kreativ ausnutzen...

Den vorhandenen Platz kreativ ausnutzen…

Den Regler selbst habe ich zwecks Masseverbindung und bestmöglicher Wärmeabfuhr direkt in die Ecke der Blechdose gelötet. Die übrigen Teile haben dann irgendwo ihren Platz gefunden und wurden frei verdrahtet. Die orangene Strippe bringt die +18V direkt von der Netzteilbuchse auf den Regler; auf einen Elko habe ich an der Stelle mal verzichtet. Innerhalb der Blechdose war kein direkter 18V-Abgriff vorhanden, was vermutlich den drei Kandidaten unten links im Bild geschuldet ist. Der Elko und die Spule sind strenggenommen etwas zu dick, der Deckel passt nicht mehr ganz drauf auf die Dose, aber im Gehäuse ist genug Platz für eine kleine Ausbuchtung.

Soviel erstmal zu den 5V. Nun müssen die nur noch irgendwie zum iPod-Connector hinkommen. Der ist mit einem 24-poligen Flachbandkabel mit dem Mainboard verbunden. Eigentlich wollte ich da gerne eine Strippe von frei machen und für meine Zwecke missbrauchen, bin aber leider dran gescheitert. Alleine 6 Pins sind für die Masse zuständig, da hätte sich locker einer oder zwei von abnehmen lassen – allerdings sind die Kontakte direkt von der Unterseite mit Vias auf den innen liegenden Masse-Layer genagelt, also konnte ich die nicht mal eben so isolieren. Ich hab’s dann aufgegeben und eine Extra-Strippe direkt zwischen die beiden Boards gelötet.

Nur 5V alleine reichen nicht

Nur 5V alleine reichen nicht

Als „Lötstützpunkt“ habe ich mir dazu mit dem Cutter eine kleine Ecke von der Massefläche abgekratzt. Das nächste Problem bestand darin, dass der Pin 8 vom iPod-Connector (der die +5V_USB haben soll) gar keine Leiterbahn auf der Platine hat. So’n mist, musste ich also das fisselige AWG-34 direkt auf den Pin löten – das sind nur 0,160 Millimeter Drahtdurchmesser – mit einer „Spitze“, die so breit ist wie drei von den Pins 🙁 . Hat dann aber geklappt und ist sogar stabil 🙂 .
Also den ganzen Quatsch wieder zusammengebaut und ausprobiert. Und siehe da – klappt nicht 🙁 . Hm. Alles noch mal durchgecheckt, 5V kommen da an wo sie sollen, also was zum Teufel…? Ein schneller Test mit dem USB-Ladekabel am Labornetzgerät hat dann gezeigt, dass der iPod sich die normgerechten 100mA genehmigt, das aber offenbar zu wenig Saft ist um den Akku aufzuladen. Naja gut, muss ich der Diva also noch ein korrektes Ladegerät vorgaukeln, damit sie sich etwas mehr Strom genehmigt. Auf pinouts.ru gibt es die nötigen Hinweise, sprich zwei Spannungsteiler zu 33k/22k und 33k/47k zwischen 5V und die beiden USB-Data-Pins. Für die vier Widerstände hat sich dann noch ein Plätzchen gefunden und die beiden Connector-Pins haben auch schon ihre eigenen Vias (die scheinbar im Nix enden) zum leichten anlöten der Strippchen. Und damit hat’s dann endlich hingehauen:

Siehe da - der Akku wird geladen!

Siehe da – der Akku wird geladen!

Irgendwo beim googeln habe ich gelesen, dass Bose wohl auch einen Umbau für dieses Dock anbietet. Sollte aber knapp EUR 100,- oder so kosten… Und ausserdem, wo bleibt da der Spass? 😉

Weiter zu den Kommentaren…


English version

Here’s yet another piece of kit I stumbled upon while dumpster diving: A Bose SoundDock complete with its power supply (but missing the remote 🙁 ). A first test with my iPod 3G showed that it basically worked flawlessly, except for a little loose joint at the supply connector. This was easily fixed with a little careful shaping of the single contacts though, and now I own a nice little sound system and saved it from the landfill for now. But there’s this little „but“…: the iPod won’t charge off the dock! Since I’m not very familiar with bitten apple technology, I had to google for a little enlightenment. It turns out that the first generations of i-Pid/Pad/Pud’s (which this dock was made for) used to receive their charge via FireWire only, and not USB, like it’s usual nowadays. So I’d have to look why there were no 5V there.

The SoundDock is powered through a SMPS with 2 x 18V @ 1A each, and so 18V was the voltage at the FireWire-Power-Pin. Inside are two linear regulators, which supply the digital logic with some 3.3V and 1.xV. No 5V there at all. Bummer. Okay, so I’d have to pull that out of the hat somewhere. Since power-hungry state-of-the-art battery-powered equipment easily sucks 2A out of the charger, I wouldn’t get away with just another linear regulator, so a switch-mode controller had to find its place inside the case. I didn’t have anything suitable handy, so I ordered a LM2576 in DDPAK case, together with a beefy schottky-diode and a 1000uF/6.3V cap. They didn’t stock any coils, so I used a 47uH salvaged from the digital audio section of a dead TV set. The regulator came as a fixed 5V part to keep external parts count low, so I only needed coil, diode and cap – and that’s it.

make some creative use of the existing space...

make some creative use of the existing space…

For a good thermal connection (and electrical conn‘ to GND, of course) I soldered the controller directly to the metal can. The other parts were then fitted within the existing space and wired accordingly. The orange wire connects the input directly to +18V from the supply connector, since there were no +18V inside the can. Coil and cap could’ve been a little smaller, since the lid doesn’t fit correctly anymore, but there’s enough room in the case anyway.

So there’s our 5V supply. Now to get them to the iPod-Connector, which is connected to the mainboard via a 24-pin flex. I planned to use one or two of that pins for my 5V, but I wasn’t able to separate them from the original traces due to some buried vias, so I ultimately soldered an extra wire between the two boards.

'5V is not enough'

‚5V is not enough‘

I separated a little pad from the GND layer to solder the 5V wire onto. The real problem however was to run a wire to the iPod-Connector, since the needed Pin 8 wasn’t connected to any trace on the board. So I had to solder my tiny 34 gauge directly to the connector pin, with a solder tip which was as wide as three of those pins 🙁 . Wasn’t easy, but in the end it worked out okay 🙂 .
So I put everything back together and… it didn’t work 🙁 . Damnation. Checked everything again, everything was working like it was supposed to, so what the hell…? To figure out what was wrong, I connected the iPod to my lab supply with an USB cable, and there it was: The pod sucked the allowed maximum of 100mA, but that was not enough to charge it! So I’d have to resemble a correct charger to convince the iPod that it’s allowed to pull some more amps. pinouts.ru has all the needed information, so I set up two voltage dividers at the USB-data pins, consisting of 33k/22k and 33k/47k between 5V and GND. Finding some space for four little chips was easy and soldering the wires to the existing vias (which didn’t connect to anything else, btw) wasn’t hard, either. And that was it:

battery is getting charged!

battery is getting charged!

While googling around I found out that Bose offers a replacement board, but that’s rather expensive, in the range of $100. And where’s the fun in that? 😉


Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.